支援新版 Plurk API (OAuth Core 1.0a) 的 Twitter To Plurk Script

code 放在「Plurk 新版 OAuth Core 1.0a 的 twitter to plurk」,其中裡面用到的 SQLite 的表格結構請參考「Twitter 轉 Plurk 的程式...」這篇文章的說明。把本來是 plaintext password 的程式換過去後看起來舒服多了,不過中間寫起來讓人頗 orz...

先是一直沒辦法透過 OAuth::Lite 送出 UTF8 內容,於是決定換成 Net::OAuth,結果因為文件內的範例都沒講到重點而倒地不起...

然後遇到 Plurk API 2.0 beta 的文件沒有列出是 GET 或是 POST,於是又試了老半天...

文件真的很重要...

Plurk API:OAuth Core 1.0a

Plurk API 2.0 beta」總算是提供 OAuth Core 1.0a 介面讓人使用了,想把之前「Twitter 轉 Plurk 的程式...」的程式改寫,不過新的 API 不管怎麼註冊都不會過...

有人有註冊成功的嗎?

PS:另外「* 如果這不是一個網頁應用程式,請留空白即可」好像也怪怪的,我記得應該反過來?