jQuery UI 會同時保持與 jQuery 1.2.6、1.3 的相容性

前陣子 jQuery 1.3 出來,但問題還不少,除了在 jQuery 官方的 bug tracker 上可以看到外,在 PIXNET 內部測試時有發現一些問題,所以就暫時維持 1.2.6... (IE6 變快不少,所以以,其他的 browser 速度都不錯)

jQuery UI 這陣子在 RC 階段,結果決定要同時維持與 jQuery 1.2.6 與 1.3 的相容性:「jQuery UI 1.7 is the new 1.6」。

jQuery UI 1.6rc6 + 修正會是 jQuery UI 1.7,這個 branch 需要使用 jQuery 1.3 或更新的版本。而 jQuery UI 1.6rc2 + 修正會是 jQuery UI 1.6,讓決定使用 jQuery 1.2.6 的人可以享受到 jQuery UI 的新功能,但這個版本在完成後就沒有打算維護,純粹只是階段性產品,讓大家有更充裕的時間測試 jQuery 1.3+...

This entry was posted in Computer, Murmuring, Network, Programming, Software, WWW. Bookmark the permalink.

3 Responses to jQuery UI 會同時保持與 jQuery 1.2.6、1.3 的相容性

  1. mrj says:

    你好~
    有個jQuery的使用問題想請教一下
    jQuery使用GPL授權
    那商業網站(例如痞客邦)如果要使用jQuery的話
    1.是需要去跟jQuery付費授權
    2.還是說依照GPL授權(感染性) 也要公開痞客邦程式碼

    我不是來找砸~因為我也想將jQuery使用在商業網站
    但找出來的資料顯示 都是以上的疑惑
    因為看到痞客邦也是使用jQuery 所以留言請教一下
    是否除了以上兩種方式 可以使用於商業網站
    感謝你~

  2. Gea-Suan Lin says:

    jQuery 是 GPL/MIT 雙重授權,請參考 http://docs.jquery.com/Licensing 這邊的列表。

  3. mrj says:

    收到~我在去研究一下
    感謝你~

Leave a Reply

Your email address will not be published. Required fields are marked *