FreeBSD 上升級到 PHP 5.2.8 的一些小細節...

PHP 5.2.8 是 security update,用 5.2.6 的人應該儘速更新。(Debian sid php5 怎麼還在 5.2.6.dfsg.1-0.1... =_=)

因為 php5-pcre 直接被納入 php5 內 (也就是不需要額外再安裝,這個 port 已經消失),而直接用 portupgrade 升級 php5 會造成 php5-pcre 不會被移除,所以需要一些強硬的手段:

# cd /var/db/pkg
# pkg_delete -f php5-pcre-*
# portupgrade -f php5*
# portupgrade -f pecl*

然後再跑 pkgdb -F 把 dependency 清理一下。

This entry was posted in Computer, FreeBSD, Murmuring, Network, OS, Security, Software, WWW. Bookmark the permalink.

4 Responses to FreeBSD 上升級到 PHP 5.2.8 的一些小細節...

  1. johnpupu says:

    破大師 似乎沒這個問題

  2. chifeng says:

    偶也发现这个问题了,直接手工pkg_delete了

  3. Pingback: [FreeBSD] 利用 portmaster 升級 PHP 5.26 -> 5.28 | 小惡魔 - 電腦技術 - 生活日記 - 美食介紹 - AppleBOY

  4. Pingback: MLChen's Blog | 升級 PHP 5.2.8 以及 WordPress 2.7

Leave a Reply

Your email address will not be published. Required fields are marked *